Light Box 系のプラグインが動かない

ブログ記事の写真をクリックすると拡大して表示することができるプラグインがある。いわゆるLight Box 系のやつでこれはjqueryというjavaとコンフリクトするらしい。jqueryを$に置き換えて動作するのだが、ほかの、例えばテーマとかプラグインも同じ$を変数として使うからのようだ。

chrome-extension://fmcdfigcdfkdghdklblbbpacikcchbbh/jquery-2.1.0.min.js:2 Uncaught TypeError: Cannot read property ‘slice’ of null

と、すべてのプラグインを止めても、このブログを表示するとエラーになる。エラーにqueryという言葉があるのだからこいつのせいなんだろ。まだ良くわかっていない。

というわけで、テーマをかえちゃったりしているのです。すみません。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください