WP plugins アップデート

WordPress のプラグインをアップデートしようとすると

「更新失敗: ディレクトリを作成できませんでした。」

となりアップデートできない。こうなると
/Users/hoge/sites/blog に .maintenance が作成され、これが生きているときこのブログにアクセスすると

「現在メンテナンス中のため、しばらくの間ご利用いただけません。」

と表示され、ブログがみえなくなっちゃう。コマンドラインでログインして
$ rm .maintenance
で削除する必要がある。
Plugins directory のmode をだれでも描き込み自由の 777 にしてもだめなのだ。
さてどうしたもんか。
WordPress 4.4–ja に自動更新 が立っているので「今すぐ更新」ボタンをクリックすると
「更新用ファイルを展開できませんでした
となって更新もできない。えーい面倒だwp-content を777 にしちゃえ。

更新を展開しています…
展開したファイルをチェックしています… 更新が必要な翻訳が一部あります。
更新が終わるまでしばらくお持ちください。
更新用ファイルを展開できませんでした
インストール失敗

んが。だめだ。

[ 追記 ]

もう一つのサーバではワンクリック ・アップデートが問題ない。これまでどっちも同じようにワンクリックで更新できていたのに。なんでだろ。そのうちできるようになることが過去にあったからな。ちと放置。